Website-Suche

Network Analyzer Wireshark 2.6.3 mit verschiedenen Fehlerbehebungen veröffentlicht


Der Open-Source-Netzwerkpaketanalysator Wireshark 2.6.3 wurde vor einigen Tagen mit verschiedenen Fehlerbehebungen und aktualisierter Protokollunterstützung veröffentlicht.

Wireshark 2.6.3 hat folgende Fehler behoben:

  • Absturz des Bluetooth-AVDTP-Dissektors.
  • Absturz des Dissektors des Bluetooth-Attributprotokolls.
  • Absturz des Radiotap-Dissektors.
  • Wireshark bleibt beim Start hängen und initialisiert externe Capture-Plugins.
  • Qt: SCTP-Dialogfeld „Assoziation analysieren“: Segmentierungsfehler beim zweimaligen Klicken auf die Schaltfläche „Filterzuordnung“.
  • Falsche Darstellung des sezierten Datenelements (NETMASK) im ISAKMP-Dissektor.
  • NFAPI dekodieren: CONFIG.request-Fehler.
  • udpdump-Frame zu langer Fehler.
  • ISDN – LAPD-Dissektor seit Version 2.5.0 defekt.
  • ASTERIX Kategorie 062/135 Die Höhe hat einen falschen Wert.
  • Wireshark kann eine SSL/TLS-Sitzung nicht entschlüsseln, wenn sie über einen HTTP-Tunnel weitergeleitet wurde.
  • TLS-Einträge in einem HTTP-Tunnel werden als „Encrypted Handshake Message“ angezeigt.
  • BTATT Dissector: Temperaturmessung: Celsius und Fahrenheit vertauscht.
  • Durchmesser AVP-Benutzerstandortinformationen, Mobilfunknetzcode nicht korrekt dekodiert.
  • Heartbeat-Meldung „Info“ wird ohne Kommatrennzeichen angezeigt. Fehler 15079.

Installieren Sie das neueste Wireshark über PPA in Ubuntu:

Da die PPA-Pakete immer ein paar Tage zu spät zum Veröffentlichungsdatum vorliegen, überprüfen Sie den PPA-Link, bevor Sie beginnen.

Das stabile Wireshark-PPA enthält die neuesten Pakete für Ubuntu 18.04, Ubuntu 16.04 und Ubuntu 14.04.

1. Öffnen Sie das Terminal, indem Sie entweder Strg+Alt+T auf der Tastatur drücken oder im App-Launcher nach „Terminal“ suchen. Führen Sie beim Öffnen den folgenden Befehl aus:

sudo add-apt-repository ppa:wireshark-dev/stable

Geben Sie Ihr Benutzerkennwort ein (aus Sicherheitsgründen kein Sternchen-Feedback), wenn Sie dazu aufgefordert werden, und drücken Sie die Eingabetaste.

2. Wenn Sie das vorherige Wireshark 2.4.x auf Ihrem System installiert haben, entfernen Sie es zuerst mit dem folgenden Befehl:

sudo apt-get remove --autoremove wireshark

3. Führen Sie abschließend nacheinander die folgenden Befehle im Terminal aus, um Wireshark 2.6.x zu installieren:

sudo apt-get update

sudo apt-get install wireshark

Deinstallieren:

Um die Software zu entfernen, öffnen Sie das Terminal und führen Sie den folgenden Befehl aus:

sudo apt-get remove --autoremove wireshark wireshark-*

Und entfernen Sie die PPA, indem Sie die Registerkarte Software & Updates -> Andere Software öffnen.